• 0
AJV1

Bachmann EZ Command Controller - N Gauge Issues?

Question

Hello gang! 

Back in 2010 when I got into model railways, I got a Bachmann EZ Command Control Centre controller - the old grey model, and it worked just fine powering and controlling OO locos. Recently, when I bought my Dapol Class 33 to get into N gauge modelling, I asked about if the controller was okay to use for N gauge models and was told yes.

Got everything home, installed the DCC chip in the loco and put it on my strip of test track. Connected the controller up, but for some reason whenever I connected the controller the loco would power on and accelerate in one direction at a constant - almost top - speed, no matter what I did on the controller. As long as the controller was on and connected to the track, the loco would charge forward and there was no way to stop or even slow it down. 

Worth mentioning that this first time I tried running the loco, I couldn't find the original plug/power cable for the controller. 

Then I found the original power cable, just connected everything up, and whilst the controller is on - nothing from the loco. No lights, no throttle, nothing at all. 

What has happened here? I've read that the controller works fine with N gauge, but that 12V is the maximum you can use for N gauge locos - and the controller is 16V AC in. I'm a bit worried I've somehow burned out the chip in the loco or something like that? Do I need a new controller, a new chip or am I just missing something really obvious? 

Share this post


Link to post
Share on other sites

0 answers to this question

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now